Confiant Dashboard UI Timeout Issues

Incident Report for Confiant

Resolved

This incident has been resolved.
Posted Jul 14, 2025 - 17:01 EDT

Investigating

We are currently investigating an issue that is affecting all of our customers on our Dashboard UI. This issue causes timeouts while loading data.
Posted Jul 14, 2025 - 15:10 EDT
This incident affected: Confiant Website.